Topic: Annoying Problem Exiting Gnome

Hello All,

I am yet another refugee from freebsdfourms.org.  I've been out of the *nix game for quite some time and with my recent purchase of a  Lenovo T61 I decided it was time to remedy that.  I have a little experience but I have found it much lacking.  This is my first attempt to use FreeBSD 7.0 on a desktop and I have found that I have plenty of little problems everywhere that are highly annoying.  The first and foremost is that I cannot exit gnome using either the GUI gnome exit application from the menu or by executing "gnome-session --kill" from a terminal.  I've been CTRL-ALT-BACKSPACING to get out of Gnome.  When I try to exit using either the provided GUI or the by executing the gnome-session --kill command in the terminal I don't get any sort of error back.  It just seems to hang.

This is the closest thing to an error I can find:

May 11 16:10:56 thinkpad console-kit-daemon[901]: GLib-CRITICAL: g_hash_table_destroy: assertion `hash_table != NULL' failed
May 11 16:10:58 thinkpad gnome-keyring-daemon[969]: couldn't allocate secure memory to keep passwords and or keys from being written to the disk

A little googling hasn't turned up anything useful.  It appears that both the errors are "inconsequential".  Anyway, if anyone has any advice on tracking this down I would appreciate it because I also have to fix my video drivers, apci, about a million port upgrade errors, crappy un-anti-aliased fonts... and so on.  What fun!

Thanks!

Re: Annoying Problem Exiting Gnome

So I know it's bad practice to bump my own thread but I tried deleting all my user specific .gnome directories (loosing my sweet customizations in the process) but alas to no avail.  I'm not quite sure what's wrong.  I have a crapload of missing packages from an system wide upgrade, perhaps that is the problem.  I don't have internet access so I seldom update things.  I recently tried to do so in hopes that it would automagically solve my gnome problem and I ended up with this.  I'm just following the guide on the FreeBSD handbook, do I need to update these individually as ports by manually going to each and building them?

* Listing the failed packages (-:ignored / *:skipped / !:failed)
    ! emulators/linux_base-fc4 (linux_base-fc-4_11)    (package not found)
    ! java/javavmwrapper (javavmwrapper-2.3)    (package not found)
    ! lang/python25 (python25-2.5.2_1)    (package not found)
    ! archivers/p5-Compress-Raw-Zlib (p5-Compress-Raw-Zlib-2.008)    (package not found)
    ! devel/p5-Time-HiRes (p5-Time-HiRes-1.9712,1)    (package not found)
    ! ftp/curl (curl-7.16.3_1)    (package not found)
    ! ftp/wget (wget-1.11)    (package not found)
    ! sysutils/coreutils (coreutils-6.9_1)    (package not found)
    ! graphics/dri (dri-7.0.1,2)    (package not found)
    ! sysutils/lsof (lsof-4.79K)    (package not found)
    ! archivers/p5-IO-Compress-Base (p5-IO-Compress-Base-2.008)    (package not found)
    ! security/libgcrypt (libgcrypt-1.4.0)    (package not found)
    ! graphics/png (png-1.2.26)    (package not found)
    ! security/p5-Authen-SASL (p5-Authen-SASL-2.10_1)    (package not found)
    ! shells/bash (bash-3.2.33)    (package not found)
    ! archivers/gtar (gtar-1.19)    (package not found)
    ! x11/xorg-libraries (xorg-libraries-7.3_1)    (package not found)
    ! textproc/aspell (aspell-0.60.6)    (package not found)
    ! net/samba-libsmbclient (samba-libsmbclient-3.0.28)    (package not found)
    ! graphics/libGL (libGL-7.0.1)    (package not found)
    ! x11-fonts/xorg-fonts (xorg-fonts-7.3)    (package not found)

Re: Annoying Problem Exiting Gnome

If you have installed portupgrade, then running portupgrade -a should take care of things; it will build the ports from source for which binary packages are not available.

Re: Annoying Problem Exiting Gnome

So I updated all my ports... and gnome still doesn't exit using it's GUI.  I guess the fix is to not use gnome...