Topic: OpenBSD, Mac OS X, and NFS

this is the configuration of my OpenBSD 4.3 NFS server:



the -n mountd flag is supposed to "not require that clients make mount requests from reserved ports."


drwxrwxrwx   2 brain  brain      512 Aug 22 11:58 share/

I can mount the NFS share with mount_nfs -P crashoverride:/share /mnt on the OS X client, but without the -P flag it gives me mount_nfs: /mnt: Permission denied.

I'd like to be able to mount the share from the OS X Finder interface and I can't pass the -P flag from there. for some reason the -n flag to mountd doesn't seem to be working. there used to be a sysctl for this but it seems to be gone. any ideas?

Re: OpenBSD, Mac OS X, and NFS

Have you tried manually starting mountd with the flag(s)? Is it showing up in ps with the flag? Which version of OSX is the client?

There's a few ways to tackle this from the client side as well depending on what you are trying to accomplish:

nfs.server.mount.require_resv_port in your nfs.conf can be set to force using the reserved port according to the man page ( … onf.5.html). I looked at a 10.4 and a 10.5 box and neither had an nfs.conf by default.

You can setup a mount in the Netinfo Manager. It can pass arguments. They can be static, autmounting and automounting on boot. The automounting options are a little trickier getting setup but are pretty nice once you get it going. I used to have automounting setup with my powerbook on 10.3/10.4. I had a folder on the desktop with all my remote shares. Double click a share and it would automatically mount the share and would unmount automatically after it wasn't in use.  I occasionally had to HUP the automount daemon when I switched between networks/VPNs/etc. The laptop is mostly independent these days so I don't have it setup on 10.5.

Of course you can always script it (applescript, shell script, python, etc.).

Re: OpenBSD, Mac OS X, and NFS

I've tried manually starting mountd with the -n flag and it still doesn't work. yes, it shows up in ps with the flag.

my OS X install is 10.4.9.

someone else suggested that stuff in nfs.conf and I created nfs.conf with that line in it, but it still didn't work hmm. I think I might just install Samba; NFS seems like more of a pain than it's worth.

Re: OpenBSD, Mac OS X, and NFS

I've done some looking around and there's a lot of questions but no answer on why it was changed. The mountd flag seems to be useless and the sysctl is long gone (3.x series). I did run across a diff for OpenBSD 4.3 that disables the check if you are interested. … ort43.diff