Topic: NetBSD 5.0.2 broken vnconfig

I can get vnconfig to attach a file to a device in the normal way, but if I use vnconfig -l to list current setting I always get an error: vnconfig: VNDIOCGET: Inappropriate ioctl for device

anyone else get this?

I am running a dom0 netbsd under xen 3.1 this is observed when logged in as root on the dom0

When I run the same command on one of the domU installs it works ok:
bsd# vnconfig -l
vnd0: not in use
vnd1: not in use
vnd2: not in use
vnd3: not in use

All installs dom0 and domU are PAE.

Re: NetBSD 5.0.2 broken vnconfig

No idea. Tried to contact people on mailing lists ?

<wintellect> NetBSD users are smart enough to accept that there's no 3D support tongue

Re: NetBSD 5.0.2 broken vnconfig

I think I may have spotted an issue, during my frantic setting up - I forgot the only kernel I could get that would support DOM0 PAE was from the HEAD branch, it's something like 5.99.24. There is no 5.02 DOM0 PAE Kernel.

I am still using the vnconfig from 5.02 release which clearly does not like the 5.99.24 kernel, maybe I will try a full HEAD install or re-compile vnconfig. Time permitting.

Re: NetBSD 5.0.2 broken vnconfig

Let us know if it worked!

<wintellect> NetBSD users are smart enough to accept that there's no 3D support tongue

Re: NetBSD 5.0.2 broken vnconfig

I am fairly sure it's simply that I am running kernel 5.99.24 without installing the correct version of vnconfig. Unfortunately I don't have the time to try the HEAD version, I did take a look but could not get it to install (the current version on the ftp site does not have a full install CD that I can get working?)

So I will wait for the next release that does include a DOM0PAE Kernel. I will put up with DOM0 not working with vnconfig fully.