Topic: Gnome2 - Epiphany-2.28.2_3 portupgrade error

Hey all,

I'm running FreeBSD 7.2-RELEASE-p7, with Gnome2.  However, I'm having this issue with upgrading my Epiphany port (2.28.2_2) to the newest version (2.28.2_3).....


epiphany-2.28.2_2                   <   needs updating (port has 2.28.2_3)


However, when I go through the normal portupgrade process for it...

# portupgrade www/epiphany


It'll start going through its checks and start compiling.  Then about midway through it'll error out with the following.....


((extra code left out))
.
.
.
CCLD   libephymain.la
  CC     epiphany-ephy-main.o
  CCLD   epiphany
  GEN    Epiphany-2.28.gir
Traceback (most recent call last):
  File "/usr/local/bin/g-ir-scanner", line 38, in <module>
    sys.exit(scanner_main(sys.argv))
  File "/usr/local/lib/gobject-introspection/giscanner/scannermain.py", line 277, in scanner_main
    transformer.register_include(include_obj)
  File "/usr/local/lib/gobject-introspection/giscanner/transformer.py", line 112, in register_include
    self._parse_include(filename)
  File "/usr/local/lib/gobject-introspection/giscanner/transformer.py", line 140, in _parse_include
    self.register_include(include)
  File "/usr/local/lib/gobject-introspection/giscanner/transformer.py", line 111, in register_include
    filename = self._find_include(include)
  File "/usr/local/lib/gobject-introspection/giscanner/transformer.py", line 129, in _find_include
    % (girname, searchdirs))
ValueError: Couldn't find include 'Atk-1.0.gir' (search path: ['.', '.', '/usr/local/share/gir-1.0', '/usr/share/gir-1.0', '/usr/local/share/gir-1.0'])
gmake[4]: *** [Epiphany-2.28.gir] Error 1
gmake[4]: Leaving directory `/usr/ports/www/epiphany/work/epiphany-2.28.2/src'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory `/usr/ports/www/epiphany/work/epiphany-2.28.2/src'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/usr/ports/www/epiphany/work/epiphany-2.28.2/src'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/www/epiphany/work/epiphany-2.28.2'
gmake: *** [all] Error 2
*** Error code 1

Stop in /usr/ports/www/epiphany.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20100414-16462-1ixxp2u-0 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=epiphany-2.28.2_2 UPGRADE_PORT_VER=2.28.2_2 make
** Fix the problem and try again.
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        ! www/epiphany (epiphany-2.28.2_2)      (unknown build error)


No sure what the above error is referring to.  Looks like some module or a line that's in error.  No clue.  My Gnome2.28 port will not upgrade because the epiphany one failed. 

Anyone have this error come up during the portupgrade/portsnap process??
Anyone know a way around this or how to fix this?

Thanks in advance!


Regards,

--Cj
CyberJedi

Re: Gnome2 - Epiphany-2.28.2_3 portupgrade error

Usually this means that your source files need to be updated.  Right now the ports tree is in a bit of a mess, since some major ports are being updated after the latest ports freeze.  Things should settle down in a week or so.  I'd suggest you wait, update your ports tree, and try again.

Re: Gnome2 - Epiphany-2.28.2_3 portupgrade error

epiphany-2.28.2_2                   <   needs updating (port has 2.28.2_3)

Only the last number (_2) changed, this means only the PORTREVISION has been bumped solving some kind of port issue, *not* updating the actual program.

In fact, in this case nothing changed, and teh revision got changed because of some change to a library:
http://www.freebsd.org/cgi/cvsweb.cgi/p … 5;r2=1.146

Don't fix it if it ain't broke.

Trust me, I know what I'm doing.

Re: Gnome2 - Epiphany-2.28.2_3 portupgrade error

Thank You very much for your input and expertise, gentlemen!  It makes sense now.  smile

--CJ