Topic: Can't SU to root - "Pam_start" issue?

Hi All,

I just upgraded my FreeBSD server (Dell PowerEdge 2550) from 6.4-Release to 7.1-Release using the FreeBSD-update tool.  The upgrade went well, considering that it doesn't have Xorg or any Desktop manager installed.  There're only 15 ports installed on it.

The only somewhat "major" issue I came across once the upgrade was completed was that some ports/binaries wouldn't run.  Either I had to reinstall some ports, or I had to re-link some library files in order to get them to work. 

One of the most notable was that I can't SU to root as I was able to prior to the upgrade.  No matter if I try SU'ing from the console itself or SSH I get this error....

%
%su
/libexec/ld-elf.so.1: su: Undefined symbol "pam_start"
%

I don't even know where to begin.  I'm not too familiar with PAM.  Anyone ever seen this before??
I tried Googling but wasn't able to find anything. 

Any assistance would be much appreciated.

Regards,

CJ

Re: Can't SU to root - "Pam_start" issue?

Just a basic question, but did you reboot after the upgrade?
This has nothing to do with PAM, for some reason the `pam_start' function cannot be found in any library.

Either I had to reinstall some ports, or I had to re-link some library files in order to get them to work.

You can install misc/compat6x, this will install FreeBSD 6 compatibility libraries. But in general it is advised to upgrade all ports.

Trust me, I know what I'm doing.

Re: Can't SU to root - "Pam_start" issue?

Hi,

Thanks for the help.

Yes, I did reboot after the upgrade.  In fact, I had to reboot a couple of times because some of the library errors I was getting were only showing up at boottime.  That's the only way to figure out which binaries were having the library issues. 

I'll go ahead and install the FreeBSD 6 compatibility libraries.  But in closing, I have upgraded all ports after the upgrade.  But I'll attempt it again.

Thanks for your advice and I'll let you know what happens. smile


---Cj

Re: Can't SU to root - "Pam_start" issue?

I attempted to upgrade my ports but it didn't need any updates. 

I just tried installing that port and then logged out of root, and log back in to see if any changes would take effect, and now I can't log back into any accounts!  Everytime I try logging in I get that same message.  I'm locked out!  sad

The only way I can log in is if I SSH into the box (since I log in using RSA authentication, and not password authentication).  Then from there I can use "sudo" to issue root commands.

Re: Can't SU to root - "Pam_start" issue?

Figured out what my issue was.  While linking some library files after the upgrade (since some binaries were complaining about missing ones), I accidentally linked a "pam" library file to a "libcrypto" file.  I removed the link now everything is back to normal!! smile

Furthermore, I've installed the FreeBSD-6x Compatibility library port.


Thanks for your suggestion! smile

Re: Can't SU to root - "Pam_start" issue?

reinstant