Topic: Installing Samba on NetBSD 3.1

faced with a few problems..

tried installing samba from source long ago but i never managed to get it working and i haven't worked on unix in a long time so here goes my newbie question >.<

when i try to install wget i get this error:
pkg_add: no pkg found for 'wget-1.11.tgz', sorry.

the reason why i need wget, is so i can use it to download the samba source files lol

can anyone help me get wget and samba installed on my server thanks big_smile

Re: Installing Samba on NetBSD 3.1

What is the exact command line you used?

Re: Installing Samba on NetBSD 3.1

hi Maxlor

i simply ran pkg_add wget-1.11.tgz but im guessing netbsd cant find that file so i went on the net and downloaded wget source and i managed to install that^^

now im working on samba problem is...

samba wants me to install autoconf:
"./autogen.sh: need autoconf 2.53 or later to build samba from git"

and autoconf wants me to install GNU M4: (whatever that is lol)
"GNU M4 1.4.6 or later is required; 1.4.14 is recommended"

so yeah its sending me around the world and back

i'll have to try again tomorrow though too tired right now..

and thanks Maxlor for your fast reply smile

Re: Installing Samba on NetBSD 3.1

ok so i managed to get M4 and autoconf working but im still not out of the woods lol

coz now i need Python and that said i needed gmake

after installing gmake and trying to compile Python it says:
gmake: *** virtual memory exhausted.  Stop.

so yeah...think im going to have to set up this server from fresh install coz it doesn't have enough swap file >.<

all this playing around just to get samba working lol

Re: Installing Samba on NetBSD 3.1

Yes, modern software has a lot of dependencies, and it's a lot of work to install something like samba manually. So... the way to do it is to use a pkgsrc on NetBSD. This chapter explains how to use binary packages: http://www.netbsd.org/docs/pkgsrc/using.html#using-pkg
Once you've done that, pkg_add samba should do the trick.

Re: Installing Samba on NetBSD 3.1

I'd suggest pkgsrc - it'll build the package you need with the latest stable version it has, as well as all dependencies required

"UBER" means I don't drink the coffee... I chew the beans instead
             -- Copyright BSDnexus