Topic: Gnome Desktop

I've installed gnome desktop in NetBSD 5.1, I can start a gnome-session after console log in. How do I get to gnome desktop by default.

Here are my configuration files -

NBSD$ cat ~/.xinitrc
exec gnome-session

cat ~/.xsession
#!/bin/sh
# $Xorg: xinitrc.cpp,v 1.3 2000/08/17 19:54:30 cpqbld Exp $

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then







    xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then







    xrdb -merge "$userresources"

fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs



gdm &
xclock -geometry 50x50-1+1 &
/usr/X11R7/bin/xterm -geometry 80x50+494+51 &
/usr/X11R7/bin/xterm -geometry 80x20+494-0 &
exec /usr/X11R7/bin/xterm -geometry 80x66+0+0 -name login
exec gdm

cat /etc/rc.conf
#    $NetBSD: rc.conf,v 1.96 2000/10/14 17:01:29 wiz Exp $
#
# see rc.conf(5) for more information.
#
# Use program=YES to enable program, NO to disable it. program_flags are
# passed to the program on the command line.
#

# Load the defaults in from /etc/defaults/rc.conf (if it's readable).
# These can be overridden below.
#
if [ -r /etc/defaults/rc.conf ]; then
    . /etc/defaults/rc.conf
fi

# If this is not set to YES, the system will drop into single-user mode.
#
rc_configured=YES

# Add local overrides below
#
wscons=YES
hostname=NBSD.NetBSD.org
dhclient=YES
defaultroute=192.168.1.1
gdm=YES
famd=YES
rpcbind=YES
dbus=YES
hal=YES

Secondly, I dont see any shutdown, hibernate or suspend option in panel.

How do I fix this.

Best,

David