Topic: Virtual mail

Hi folks,

OpenBSD4.0 amd64
Postfix_2.4.3
Mysql
$ mysql --version
mysql  Ver 14.12 Distrib 5.0.24a, for unknown-openbsd4.0 (x86_64) using readline 4.3

On running
$ mysql -u vmailuser -p password123
Enter password:
ERROR 1045 (28000): Access denied for user 'vmailuser'@'localhost'
(using password: YES)

The password is correct found on ;
/etc/postfix/mysql-aliases.cf
/etc/postfix/mysql-client.cf
/etc/postfix/mysql-recipient.cf
/etc/postfix/mysql-relocated.cf
/etc/postfix/mysql-sender.cf
/etc/postfix/mysql-transport.cf
/etc/postfix/mysql-domains.cf
/etc/postfix/mysql-virtual-maps.cf
/etc/postfix/mysql-virtual.cf
etc.

Please help.  TIA


B.R.
satimis

Re: Virtual mail

Are you sure that there's a user called 'vmailuser' in mysql ?

mysql> select user,host from mysql.user;
Keep Smiling

Re: Virtual mail

hi

just run
$ mysql -u vmailuser -p
Enter password: type in your password here

the way you ran it, mysql thinks that password123 is one of the databases

Last edited by hamba (2007-06-09 14:33:31)

Re: Virtual mail

arun wrote:

Are you sure that there's a user called 'vmailuser' in mysql ?

mysql> select user,host from mysql.user;

Hi arun,


Just tried to create a virtual user "albert" by performing following steps;

$ su
password (as root)
# su - _vmail
$ mkdir satimis.com/albert
$ maildirmake satimis.com/albert/Maildir
$ maildirmake -q 10000000S satimis.com/albert/Maildir

All went through w/o complaint.


Then

$ mysql -u vmailuser -p

to start mysql to input follows;

mysql> insert into postfix_virtual_domains values
('1','satimis.com','maildrop:');

mysql> insert into postfix_users
(email,clear,name,homedir,maildir,quota) values
('albert@satimis.com','UzeR0nePazz','The name of the
person','/var/mail/vmail','satimis.com/albert/Maildir/','10000000');

I was held there.  Please help.  TIA


B.R.
satimis

Re: Virtual mail

hamba wrote:

hi

just run
$ mysql -u vmailuser -p
Enter password: type in your password here

the way you ran it, mysql thinks that password123 is one of the databases

Hi hamba,

Tried;

1)
$ mysql -u vmailuser -p
Enter password:  (satimis' password)
ERROR 1045 (28000): Access denied for user 'vmailuser'@'localhost' (using password: YES)

2)
$ mysql -u vmailuser -p
Enter password:  (root password)
ERROR 1045 (28000): Access denied for user 'vmailuser'@'localhost' (using password: YES)

None of them can work.


B.R.
satimis

Re: Virtual mail

Its not working because you need to use the password for the user vmailuser

so let say you want to login as satimis you will do it as follow

$ mysql -u satimis -p
Enter password:  (satimis' password)

or as root

$ mysql -u root -p
Enter password:  (root password)

or as vmailuser

$ mysql -u vmailuser -p
Enter password:  (vmailuser' password)

seeing that vmailuser already have a password you should find it in your /etc/postfix/mysql-* files

if you can't remember the password log in with the root account and then change the password for the vmailuser

$ mysql -u root -p
Enter password:  (root password)
mysql> use mysql;
mysql> update user set password=PASSWORD("NEWPASSWORD") where User='vmailuser';
mysql> flush privileges;

Also remember to change the password in all the files where you use the user vmailuser or you would not be able to log in.

Re: Virtual mail

hamba wrote:

Its not working because you need to use the password for the user vmailuser

so let say you want to login as satimis you will do it as follow

$ mysql -u satimis -p
Enter password:  (satimis' password)

or as root

$ mysql -u root -p
Enter password:  (root password)

or as vmailuser

$ mysql -u vmailuser -p
Enter password:  (vmailuser' password)

seeing that vmailuser already have a password you should find it in your /etc/postfix/mysql-* files

Hi hamba

I tried many times before w/o a solution.

$ mysql -u satimis -p

Enter password: 
ERROR 1045 (28000): Access denied for user 'satimis'@'localhost' (using password: YES)

$ mysql -u root -p

Enter password: 
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

$ mysql -u vmailuser -p

Enter password: 
ERROR 1045 (28000): Access denied for user 'vmailuser'@'localhost' (using password: YES)

I think mysql has not been properly configured.  I'm now googling around.


Others noted with tks.


Edit:
New discovery;

$ mysql -u root

             
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 13 to server version: 5.0.24a-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> quit
Bye

$ mysql -u satimis

ERROR 1045 (28000): Access denied for user 'satimis'@'localhost' (using password: NO)

$ mysql -u vmailuser

ERROR 1045 (28000): Access denied for user 'vmailuser'@'localhost' (using password: NO)

satimis

Last edited by satimis (2007-06-09 17:08:13)

Re: Virtual mail

manually add users to the database from within mysql - then flush privileges

"UBER" means I don't drink the coffee... I chew the beans instead
             -- Copyright BSDnexus

Re: Virtual mail

Hi WIntellect,

Tks for your advice.

manually add users to the database from within mysql - then flush privileges

Could you please provide more detail.

root can login mysql w/o password

# mysql -u root

Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 5 to server version: 5.0.24a-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql>

What users shall I add;

vmailuser
satimis
albert
???

and how to add them including prespective password ???

Which mysql file holds those information.  TIA


B.R.
satimis

Re: Virtual mail

http://dev.mysql.com/doc/refman/5.1/en/ … leges.html

that might help.

11

Re: Virtual mail

satimis wrote:

root can login mysql w/o password

this is insecure, you should change root password for mysql

SET PASSWORD FOR 'root'@'localhost'=PASSWORD('newpassword');
satimis wrote:

What users shall I add;

the username doesn't really matter, because mysql users are quite different from system users, you can even create your own user, which doesn't have the corresponding system user (I would go for this). just be sure to specify the correct username in postfix configuration files (mysql_*.cf, etc)

satimis wrote:

and how to add them including prespective password ???

a la

GRANT ALL PRIVILEGES ON `demodatabase`.* TO 'demouser'@'localhost' IDENTIFIED BY 'demopassword';

the GRANT statement enables system administrators to create MySQL user accounts and to grant rights to from accounts. the IDENTIFIED BY clause is only needed if user is non-existent, so don't use it if you already have the necessary user created (but I assume you don't).

btw, check out this great guide, which was the reason I registered at forums.bsdnexus smile

Re: Virtual mail

good answer mad!

"UBER" means I don't drink the coffee... I chew the beans instead
             -- Copyright BSDnexus

Re: Virtual mail

Hi mad,

Tks for your advice.


this is insecure, you should change root password for mysql

SET PASSWORD FOR 'root'@'localhost'=PASSWORD('newpassword');

Done.

$ mysql -u root

Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 2 to server version: 5.0.24a-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql>

mysql> SET PASSWORD FOR 'root'@'localhost' = Password('mypasswd');

Query OK, 0 rows affected (0.02 sec)

I made a mistake here, "Password" not all characters in capital.  Does it matter.

Now
$ mysql -u root
password

Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 2 to server version: 5.0.24a-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql>

But failed to run;

-> SET PASSWORD FOR 'root'@'home.openbsd101' = Password('mypasswd');

ERROR 1133 (42000): Can't find any matching row in the user table

-> SET PASSWORD FOR 'root'@'home.openbsd101' = PASSWORD('mypasswd');

ERROR 1133 (42000): Can't find any matching row in the user table
satimis wrote:

What users shall I add;

the username doesn't really matter, because mysql users are quite different from system users, you can even create your own user, which doesn't have the corresponding system user (I would go for this). just be sure to specify the correct username in postfix configuration files (mysql_*.cf, etc)

I added
$ mkdir -p satimis.com/albert
$ maildirmake satimis.com/albert/Maildir
$ maildirmake -q 10000000S satimis.com/albert/Maildir
$ ls satimis.com/albert/Maildir

creating an account for "albert"

# ls -l /var/mail/vmail/satimis.com/albert/     

                               
total 4
drwx------  5 _vmail  _vmail  512 Jun  8 23:46 Maildir

# find / -name mysql-*.cf

/etc/postfix/mysql-aliases.cf
/etc/postfix/mysql-client.cf
/etc/postfix/mysql-recipient.cf
/etc/postfix/mysql-relocated.cf
/etc/postfix/mysql-sender.cf
/etc/postfix/mysql-transport.cf
/etc/postfix/mysql-domains.cf
/etc/postfix/mysql-virtual-maps.cf
/etc/postfix/mysql-virtual.cf

Shall I create his acount on all mysql-*.cf manually as follow;

user = albert
password = albertpasswd
dbname = mail
table = postfix_alias
select_field = destination
where_field = alias
hosts = localhost
satimis wrote:

and how to add them including prespective password ???

a la

GRANT ALL PRIVILEGES ON `demodatabase`.* TO 'demouser'@'localhost' IDENTIFIED BY 'demopassword';

the GRANT statement enables system administrators to create MySQL user accounts and to grant rights to from accounts. the IDENTIFIED BY clause is only needed if user is non-existent, so don't use it if you already have the necessary user created (but I assume you don't).

I don't have users created except albert as mentioned above. 

Shall I run;

GRANT ALL PRIVILEGES ON `demodatabase`.* TO 'demouser'@'localhost' IDENTIFIED BY 'demopassword';

What shall I replace for 'demodatabase', 'demouser' and 'demopassword'???  Tks.

btw, check out this great guide, which was the reason I registered at forums.bsdnexus smile

Noted with tks

B.R.
satimis

Last edited by satimis (2007-06-11 10:47:03)

Re: Virtual mail

After you have updated a password or added a user or granted a user access to a database you always have to run flush privileges, this will let mysql know of changes that you have made.

Last edited by hamba (2007-06-11 14:17:16)

Re: Virtual mail

hamba wrote:

After you have updated a password or added a user or granted a user access to a database you always have to run flush privileges, this will let mysql know of changes that you have made.

Hi hamba,

I did it before without success.

-> FLUSH PRIVILEGES;

ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near PASSWORD
SET PASSWORD FOR 'root'@'host.satimis.com' = PASSWORD
FLUSH PRIVILEGES' at line 1
mysql>

Now something strange happend here.  After several reboots

# mysql -u root

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

# mysql -u root -p

Enter password: 
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

Now I can't login with root's password.

As user the same
$ mysql -u root

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

$ mysql -u root -p

Enter password: 
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

I don't know what is its cause.  I haven't installed new package nor run update.


Edit:

I discovered the mistake committed by me.  I must use the password "mypasswd" on running;

mysql> SET PASSWORD FOR 'root'@'localhost' = PASSWORD('mypasswd');

NOT the system admin password.


satimis

Last edited by satimis (2007-06-11 16:01:54)

16

Re: Virtual mail

sorry, I was offline for a week.

I must use the password "mypasswd" [..] NOT the system admin password.

yeah, mysql users are in no way connected to system users smile

Shall I create his acount on all mysql-*.cf manually as follow;

Code:
user = albert
password = albertpasswd
dbname = mail
table = postfix_alias
select_field = destination
where_field = alias
hosts = localhost

What shall I replace for 'demodatabase', 'demouser' and 'demopassword'???  Tks.

no, you should create entry for him in the mysql table corresponding to mail users. for example, my *.cf files are based on the guide I mentioned in a post above, so my transport.cf is:

user=uname
password=passwd
dbname=maildb
table=transport
select_field=transport
where_field=domain
hosts=localhost

so I have mysql user "uname" with password "passwd", and also I have mysql database called "maildb" (that should answer the second question).

to add user "albert" on domain "satimis.com" you should to insert appropriate entries in transport, users and virtual tables. I usually do this "by hand", but there is also a frontend for that - postfixadmin. I can't really remember whether it supports custom table structure or it forces you to use their.

hmm, quoting makes my posts unreadable sad

Re: Virtual mail

Hi mad,

sorry, I was offline for a week.

That is Ok.  Tks


I solved my problem by running;
$ mysql -u root -p

Enter password: 
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 4 to server version: 5.0.24a-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> grant all privileges on mail.* to vmailuser@localhost identified
by 'password123' 
    -> grant all privileges on mail.* to vmailuser@127.0.0.1 identified
by 'password123' 
    -> quit
    -> \q
Bye

Then I can login with "password123" and created mail box for "albert".

# ls -l /var/mail/vmail

total 24
-rwx------  1 _vmail  _vmail  776 Sep 17  2006 .cshrc
-rwx------  1 _vmail  _vmail  317 Sep 17  2006 .login
-rwx------  1 _vmail  _vmail  105 Sep 17  2006 .mailrc
-rw-------  1 _vmail  _vmail  185 Jun 13 12:43 .mysql_history
-rwx------  1 _vmail  _vmail  218 Sep 17  2006 .profile
drwxr-xr-x  3 _vmail  _vmail  512 Jun  8 23:39 satimis.com

# ls -l /var/mail/vmail/satimis.com/

                                            
total 4
drwxr-xr-x  3 _vmail  _vmail  512 Jun  8 23:40 albert

# ls -l /var/mail/vmail/satimis.com/albert/

total 4
drwx------  5 _vmail  _vmail  512 Jun  8 23:46 Maildir

# ls -l /var/mail/vmail/satimis.com/albert/Maildir/

total 16
drwx------  2 _vmail  _vmail  512 Jun  8 23:40 cur
-rw-r--r--  1 _vmail  _vmail   36 Jun  8 23:46 maildirsize
drwx------  2 _vmail  _vmail  512 Jun  8 23:40 new
drwx------  2 _vmail  _vmail  512 Jun  8 23:46 tmp

I faced another problem.  Profix can send mail but can't receive mails.

$ telnet localhost 25

Trying ::1...
telnet: connect to address ::1: Connection refused
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 mail.satimis.com ESMTP Postfix

ehlo satimis.com

250-mail.satimis.com
250-PIPELINING
250-SIZE 10240000
250-ETRN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN

mail from: mail@satimis.com

250 2.1.0 Ok

rcpt to: xxx@yahoo.com

250 2.1.5 Ok

data

354 End data with <CR><LF>.<CR><LF>

(what is "354 End data with <CR><LF>.<CR><LF>"???)

subject: Testing

This is a test
.[Enter]

250 2.0.0 Ok: queued as 2C645A1CBE
quit
221 2.0.0 Bye
Connection closed by foreign host.

Mail received. 

But

subject: Testing

This is a test

all on mail body.  "Testing" not on the subject box ???


Sent test mails to admin@satimis.com on Yahoo website but was rejected with following warning;

Hi. This is the qmail-send program at yahoo.com.
I'm afraid I wasn't able to deliver your message to the following 
addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<admin@satimis.com>:
220.232.213.178 does not like recipient.
Remote host said: 554 5.7.1 <admin@satimis.com>: Relay access denied
Giving up on 220.232.213.178.

220.232.213.178 is the fixed IP of this mail server.


I leave the rest part a while after solving this problem first.  Tks.


B.R.
satimis

Re: Virtual mail

 354 End data with <CR><LF>.<CR><LF>

This means that you should end your mail body with a dot on its own line.
<CR><LF> = Newline character (ie press Enter/Return) [ for more, http://en.wikipedia.org/wiki/Line_feed ]
This is how the smtp daemon recognises end of the mail.

And iirc, "subject" is not a valid smtp command. So "subject: Testing" is taken as a part of mail body. And about the "relay access denied error", I think your smtp server is not confuigured to accept mails for the domain satimis.com and is trying to relay the mail. Add satimis.com to mydestination parameter in main.cf .

Keep Smiling

Re: Virtual mail

Hi arun,


Tks for your advice and URL

 354 End data with <CR><LF>.<CR><LF>

This means that you should end your mail body with a dot on its own line.
<CR><LF> = Newline character (ie press Enter/Return) [ for more, http://en.wikipedia.org/wiki/Line_feed ]
This is how the smtp daemon recognises end of the mail.

And iirc, "subject" is not a valid smtp command. So "subject: Testing" is taken as a part of mail body. And about the "relay access denied error",

Noted with tks.

I think your smtp server is not confuigured to accept mails for the domain satimis.com and is trying to relay the mail. Add satimis.com to mydestination parameter in main.cf .

# cat /etc/postfix/main.cf | grep mydestination

                               
# The mydestination parameter specifies the list of domains that this
mydestination = $myhostname

Whether replace "$myhostname" with "satimis.com" ???

OR

add "satimis.com" as;

mydestination = $myhostname, satimis.com

TIA


B.R.
satimis

Re: Virtual mail

mydestination = $myhostname, satimis.com

That should be the right way. If you replace $myhostname, it won't accept local mails.

-Arun

Keep Smiling

Re: Virtual mail

arun wrote:
mydestination = $myhostname, satimis.com

That should be the right way. If you replace $myhostname, it won't accept local mails.

Hi Arun,


I spent couple days unable to resolve the problem.


Made several tests by adjusting "mydestination" on main.cf;

mydestination = $myhostname
mydestination = $myhostname, satimis.com
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain, mail.$mydomain, www.$mydomain,

and sent mails on my ISP site to admin@satimis.com of this server with
following results;

----- The following addresses had permanent fatal errors -----
<admin@satimis.com>
(reason: 553 sorry, relaying denied from your location [202.64.33.147]
(#5.7.1))

----- Transcript of session follows -----
451 4.4.1 reply: read error from smtp.satimis.com.
... while talking to mailstore1.secureserver.net.:
>>> DATA
<<< 553 sorry, relaying denied from your location [202.64.33.147]
(#5.7.1)
550 5.1.1 <admin@satimis.com>... User unknown
<<< 503 RCPT first (#5.5.1)
----- The following addresses had permanent fatal errors -----
<admin@satimis.com>
(reason: 553 sorry, relaying denied from your location [202.64.33.147]
(#5.7.1))

----- Transcript of session follows -----
451 4.4.1 reply: read error from smtp.satimis.com.
... while talking to mailstore1.secureserver.net.:
>>> DATA
<<< 553 sorry, relaying denied from your location [202.64.33.147]
(#5.7.1)
550 5.1.1 <admin@satimis.com>... User unknown
<<< 503 RCPT first (#5.5.1)
----- The following addresses had permanent fatal errors -----
<admin@satimis.com>
(reason: 554 5.7.1 <admin@satimis.com>: Relay access denied)

----- Transcript of session follows -----
... while talking to smtp.satimis.com.:
>>> DATA
<<< 554 5.7.1 <admin@satimis.com>: Relay access denied
554 5.0.0 Service unavailable
<<< 554 5.5.1 Error: no valid recipients

etc.


$ postconf -n

broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
content_filter = smtp-amavis:[127.0.0.1]:10024
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
disable_vrfy_command = yes
home_mailbox = Maildir/
html_directory = no
inet_interfaces = all
inet_protocols = ipv4
local_recipient_maps = $alias_maps $virtual_mailbox unix:passwd.byname
mail_owner = _postfix
mailq_path = /usr/bin/mailq
manpage_directory = /usr/local/man
mydestination = $myhostname
mydomain = satimis.com
myhostname = mail.satimis.com
mynetworks = 127.0.0.0/8, 192.168.x.y/24
newaliases_path = /usr/bin/newaliases
queue_directory = /var/spool/postfix
readme_directory = no
sample_directory = /etc/postfix
sendmail_path = /usr/sbin/sendmail
setgid_group = _postdrop
smtp_tls_session_cache_database = btree:/var/run/smtp_tls_session_cache
smtpd_data_restrictions = reject_unauth_pipelining
smtpd_etrn_restrictions = reject
smtpd_helo_required = yes
smtpd_helo_restrictions = permit_mynetworks       
permit_sasl_authenticated        reject_inva
lid_hostname        reject_non_fqdn_hostname
smtpd_recipient_restrictions = permit_mynetworks       
permit_sasl_authenticated        reject
_unauth_destination        check_client_access
regexp:/etc/postfix/permit_client_nots25r       
 reject_invalid_hostname        reject_non_fqdn_sender       
reject_non_fqdn_hostname        r
eject_unknown_sender_domain        reject_non_fqdn_recipient       
reject_multi_recipient_boun
ce        check_policy_service inet:127.0.0.1:10023        permit
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_security_options = noanonymous
smtpd_sender_restrictions = permit_mynetworks       
reject_non_fqdn_sender        reject_unkno
wn_sender_domain
smtpd_tls_cert_file = /etc/postfix/postfix.pem
smtpd_tls_key_file = $smtpd_tls_cert_file
smtpd_tls_loglevel = 1
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
unknown_local_recipient_reject_code = 550
virtual_gid_maps = static:1003
virtual_mailbox_base = /home/vmail
virtual_minimum_uid = 100
virtual_transport = maildrop
virtual_uid_maps = static:1003

Advice would be appreciated.  TIA


B.R.
satimis

Re: Virtual mail

----- The following addresses had permanent fatal errors -----
<admin@satimis.com>
(reason: 553 sorry, relaying denied from your location [202.64.33.147]
(#5.7.1))

----- Transcript of session follows -----
451 4.4.1 reply: read error from smtp.satimis.com.
... while talking to mailstore1.secureserver.net.:
>>> DATA
<<< 553 sorry, relaying denied from your location [202.64.33.147]
(#5.7.1)
550 5.1.1 <admin@satimis.com>... User unknown
<<< 503 RCPT first (#5.5.1)
----- The following addresses had permanent fatal errors -----
<admin@satimis.com>
(reason: 553 sorry, relaying denied from your location [202.64.33.147]
(#5.7.1))

Seems like GoDaddy has a filter in place. I think you need to talk to them.

Last edited by arun (2007-06-27 09:29:58)

Keep Smiling

Re: Virtual mail

arun wrote:

Seems like GoDaddy has a filter in place. I think you need to talk to them.

Just visited godaddy.com

MyAccount --> ManageDomains --> satimis.com --> Total DNS Control and MX record;

Total DNS Control

satimis.com
A (Host)
Host      Points To                      TTL        Actions
@          220.232.213.178             1 Hour    Edit/Remove



CNAMES (Aliases)
Host      Points To                      TTL       Actions
email     @                                 1 Hour   Edit/Remove
    
mail       @                                  1 Hour   Edit/Remove
    
webmail   @                              1 Hour    Edit/Remove
    
pop     @                                  1 Hour    Edit/Remove 
    
e     @                                     1 Hour     Edit/Remove
    
smtp     @                                 1 Hour   Edit/Remove 
    
ftp     @                                   1 Hour    Edit/Remove
    
www     @                               1 Hour    Edit/Remove
    
mobilemail     mobilemail-v01.prod.mesa1.secureserver.net     1 Hour    Edit/Remove
    
pda     mobilemail-v01.prod.mesa1.secureserver.net                    1 Hour    Edit/Remove
    


MX (Mail Exchange)
Priority      Host         Goes To                             TTL          Actions
0                 @            smtp.satimis.com              1 Hour    Edit/Remove
    
10                @     mailstore1.secureserver.net      1 Hour      Edit/Remove

IIRC it has not been changed.  Previously postfix can receive mails while running on Ubuntu 6.04 which was also tested on this box.  Later I wiped out Ubuntu and installed OpenBSD 4.0

That was the story.


B.R.
satimis