Topic: "re1: watchdog timeout" screwing up my attempts to build a home router

I'm running OpenBSD 4.3-STABLE on a Commell LE-565.  It has 4 x Realtek RTL8110S-32 gigabit ethernet controllers.  They all appear as reX.

I'm using re0 to connect to Netgear DM111P ADSL2+ modem which I've configured to use RFC 2684 (formerly 1483) Bridged Ethernet over ATM.  This part of my OpenBSD router is working without a hitch.

I'm using re1 as the interface which my home network plugs into.

My linux laptop connects to the OpenBSD router on re1 without a hiccup but it keeps getting disconnected when the OpenBSD router reports "re1: watchdog timeout".  This happen around every 5-10 seconds.  It's really annoying.  I'm new to all this networking stuff and, yes, I've read the FAQ.  I'm still new to OpenBSD so I would really appreciate any suggestions.  Is there any way I can stop the annoying "re0: watchdog timeout"?

I've set up /etc/dhcpd.interfaces as:


My /etc/dhcpd.conf is:

subnet netmask {
option routers;
option domain-name "";
option domain-name-servers,;

/etc/rc.conf.local includes:


/etc/sysctl.conf includes:


and, for what it's worth, my /etc/pf.conf is:

tcp_services="{ 22, 113 }"
set block-policy return
set loginterface $ext_if
set skip on lo
scrub in
nat on $ext_if from !($ext_if) -> ($ext_if:0)
nat-anchor "ftp-proxy/*"
rdr-anchor "ftp-proxy/*"
rdr pass on $int_if proto tcp to port ftp -> port 8021
block in
pass out keep state
anchor "ftp-proxy/*"
antispoof quick for { lo $int_if }
pass in on $ext_if inet proto tcp from any to ($ext_if) port $tcp_services flags S/SA keep state
pass in inet proto icmp all icmp-type $icmp_types keep state
pass quick on $int_if

Last edited by Shagbag (2008-10-25 15:51:39)

Re: "re1: watchdog timeout" screwing up my attempts to build a home router

see if your network card is sharing an IRQ with anything else in the BIOS settings. if it is, change one of them.

also see if you can disable ACPI in your BIOS.

I found both of these suggestions by googling openbsd "watchdog timeout" (I actually found another thread on these forums as well).

Re: "re1: watchdog timeout" screwing up my attempts to build a home router

I tried disabling ACPI in the BIOS and it slowed the machine down to the point that I had to hit the enter key several times just to see the boot progress.
I disabled ACPI in the kernel but that didn't fix it.
As to IRQs, I'm afraid I'm out of my depth on that sad  I scanned the BIOS and there are some IRQs but none suggested they were used on the LAN controllers.

I tried OpenBSD in my VIA MII-6000 which has a Netgear GA511 Gigabit card (PCMCIA).  DHCP works without a hitch on that so I think it's the Commell LE-565 mobo.  I've also noticed that there is no flashing cursor - at all which appears to be another problem with this mobo.

I think my dreams of running a Gigabit OpenBSD router have been dashed and I will have to settle for the 10/100 "Fast" ethernet on my VIA MII-6000.  For now, anyway.  I see Soekris is coming out with a 4 x Gigabit board in 2009.  I may decide to buy one of those.

Of course, there's always OpenBSD 4.4 next month but from the changelogs I don't hold much hope for it fixing the problem (which appears to be a hardware problem, anyways).

Re: "re1: watchdog timeout" screwing up my attempts to build a home router

I'm running PF on 4.3-STABLE on my MII-6000 as I type.  This is progress (albeit not Gigabit) but, for the first time, I'm actually USING OpenBSD and it's not just 'a curiosity' to me anymore cool