Topic: Can't connect FBSD v6.3 wireless to AP via WPA with SSID "hidden"

Hey guys,

Has anyone experienced the following....

I have a laptop running FBSD v6.3 with an Atheros 5212 onboard wireless nic.

I can connect to my wireless LAN (Netgear WG602v2 Access Point) with no problems with WPA-enabled and SSID "broadcast".
However, when I disable SSID broadcast on the AP (WPA is still used), and try connecting that way it won't let me on the network.  The same applies if I were to use WEP (which I don't, but just wanted to test it).

Even if I add the BSSID parameter for the access point in my /etc/wpa_supplicant.conf file, it still won't connect.

Any ideas to this???   Is this a bug or is there a special parameter that I'm missing that I need to supply in order to connect to a hidden SSID??


Regards!!


--Cj

Re: Can't connect FBSD v6.3 wireless to AP via WPA with SSID "hidden"

Hello again..

Nevermind!  I figured it out!

There's an option that must be placed in the /etc/wpa_supplicant.conf file called, "scan_ssid".   It can either be set to "0" or "1".   Setting it to "1" allows your nic to scan for cloaked SSIDs so that it can see them right when your nic attempts to connect.   smile


Just a little tidbit for anyone who tries to connect to a hidden SSID using encrpytion (WEP or WPA-PSK[2]), using FreeBSD wireless.


--Cj