Topic: Network problem with NetBSD 3.1, 4, 5

Hello,

After the installation, and before reboot, the network is ok (Ethernet RTL 6139) : inet, gateway
After reboot, the card is "not configured".
ifconfig rtk0 : not inet adress
ifconfig up rtk0 does not change anything.
ping "gateway IP" : unknown host.
I've tried ifconfig inet 192.168.1.4 rtk0 : OK, but gateway (router) does not answer.
Thanks for help.

ahlsner

Re: Network problem with NetBSD 3.1, 4, 5

Can you post your /etc/rc.conf file and the output of ifconfig?

"An educator never says what he himself thinks, but only that which he thinks it is good for those whom he is educating to hear."
-Nietzsche

Re: Network problem with NetBSD 3.1, 4, 5

RoddieRod,

Thanks.
For /etc/rc.conf

______________________________
if [-r /etc/defaults/rc.conf], then
. /etc/defaults/rc.conf
fi


rc_configured=YES

WScons=YES
_____________________________

and for ifconfig rtk0 :

______________________________________________________
rtk0: flags=8802<BROADCAST,SIMPLEX,MULTICAST>mtu 1500
adress 00: .................
media ethernet autoselect
Status:active
______________________________________________________

As you see, there is no inet IP adress

ahlsner

Re: Network problem with NetBSD 3.1, 4, 5

try adding this:

ifconfig_rtk0="DHCP"

or

ifconfig_rtk0="<ip_address>"

"An educator never says what he himself thinks, but only that which he thinks it is good for those whom he is educating to hear."
-Nietzsche

Re: Network problem with NetBSD 3.1, 4, 5

RoddieRod,

Thanks for your answer.
Please, where I must write 'ifconfig_rtk0="DHCP"'?
I've tried in /etc/rc.conf : no change for the network.
Also, I've created a file :

/etc/mygate

with the default gateway before add the previous line in /etc/rc.conf
For advance,
thanks,

ahlsner

PS : i've read your answer in General BSD

Re: Network problem with NetBSD 3.1, 4, 5

try looking at this:

http://wiki.netbsd.se/How_to_gather_net … _on_NetBSD

"An educator never says what he himself thinks, but only that which he thinks it is good for those whom he is educating to hear."
-Nietzsche

Re: Network problem with NetBSD 3.1, 4, 5

RoddieRod,

Thanks.
I-ve tried your links and other from;NetBSD : no success.
Now, I try with booting the install CD, Utility (post configuration, because in this context the gateway is recognized.

ahlsner

Re: Network problem with NetBSD 3.1, 4, 5

Hello,

Ater booting on the CD 3.1, Utility, configure Network, the gateway as DNS, the access to Internet is OK.
I've done ping on some websites : test OK.
After rebooting, no access to Internet.
Have you an idea?
Thanks,

ahhlsner

Re: Network problem with NetBSD 3.1, 4, 5

try this forum http://www.daemonforums.org/index.php or the netbsd mailing  list, you may get more response.

"An educator never says what he himself thinks, but only that which he thinks it is good for those whom he is educating to hear."
-Nietzsche

Re: Network problem with NetBSD 3.1, 4, 5

RoddieRod,

Thanks,

alhner

Re: Network problem with NetBSD 3.1, 4, 5

Hello RoddieRod,

Now, the network runs.

rc.conf
aoto_ifconfig=YES

ifconfig.rtk0
inet 192.168.2.111
netmask 255.255.255.0
media autoselect

Now, I wish DHCP for RTL 8139.
A member guest me to read man pages for dhclient and dhclient.conf.
This appears to me not simple.
I wish also install a desktop as gnome or kde via pkg_add as I've done with OpenBSD.
pkg_add : for install binaries packages?
pkg_src : for compile and install?
Thank you very for your help.
Good bye

ahlsner

Last edited by ahlsner (2009-08-05 21:31:14)

Re: Network problem with NetBSD 3.1, 4, 5

How goes it Ahlsner,

I have to admit, I never installed binary packages on NetBSD I used pk_src and compiled everything when I used it.

For DHCP try adding this to your /etc/rc.conf

dhclient=YES
dhclient_flags="rtk0"

Not sure, but you may have to rename or remove ifconfig.rtk0

I've never used gnome and I have used KDE in 8 or so years.

I'm using mainly FreeBSD and OpenBSD these days with OpenBox for my desktop.

Good Luck!

"An educator never says what he himself thinks, but only that which he thinks it is good for those whom he is educating to hear."
-Nietzsche

Re: Network problem with NetBSD 3.1, 4, 5

Hello,

I come to thank you for your help and say resolved problem.
In the link you have done, a member has answer. He has only added in his rc.conf :

dhclient=YES

as you propose.
Before, I've "diesed" auto_ifconfig=YES and the lines in ifconfig.rtk0.
I-ve forgot /etc/mygate.
Since some days, I've desactived "ifconfig_rtk0="DHCP"" because conflicts with other parameters.
Now, I known two ways for configure NIC : DHCP and auto_ifconfig=YES

For my other problem, two members have installed NetBSD with DesktopBSD OR OpenBSD already installed : no troubleshooting.
They and me don't understand.
Happy week-end,

ahlsner